GeekRamble

My laptop PC, which is running MS Vista Home Premium (read: “shite”), is getting more and more dodgy these days.

Along with having a Vista OS, the hardware is HP – which I should have gone with my instincts on and NOT purchased. This particular line of Pavilions has a number of known hardware problems, including batteries which may explode, and a built-in wireless card which eventually quits working (mine has).

Plus, I did the stupid thing and accidentally hit the Express button in Windows Update not too long after I got this thing, and MS automatically installed the wrong driver for something, which completely screwed up my network and sound, which I had to fix in a rigged kind of way, and from then on my System Information has been blank. Therefore, some things don’t show up when they should when I go to Windows Update.

I backed up the hard drive last night, and defragged, and now I’m trying to figure out what else might be around to help this stupid thing run better. I saw stuff about Vista Service Pack 2 – and I haven’t installed that. Then I wondered if I’ve even installed SP1… I checked Windows Update Log, and sure enough, there is no service pack listed. This computer never even told me it needed to be installed, because by the time it came out, my system information was screwed.

So I’m downloading crap now, and hopefully this thing doesn’t explode.

I suppose, if it does, I have my other computer, though it’s a bit slower…

Damn things. :P

Posted 22 Jul 2009. Tagged | | .
Both comments and pings are currently closed.

 

Comments are closed.